Screaming Eagle's "talon" progress

Page 1 of 2 1, 2  Next

View previous topic View next topic Go down

Screaming Eagle's "talon" progress

Post by Gdmbat85 on Wed Apr 23, 2008 8:44 am

Well this thread is mainly for you, Nikki. I figured instead of calling you everyday and bothering you with updates, I'd just make a thread with the progress I've made on your car and you can just check here whenever you have time. My car is going to remain untouched until I get a new clutch and trans so your car is the main focus right now. Here's the progress so far - hopefully in the correct order:

- Your drivetrain is really noisy, lol.
- Figured out how to get your key out (after spending all night looking at wiring diagrams, only to find out it had nothing to do with wiring).
- Swapped batteries which fixed your charge/alarm issue.
- Checked your speedo wiring. All looks correct. Maybe it's the actual sensor. I'll have to wait for a free jack to test it.
- Found the pass. side door handle bezel in the trunk while looking at the amp wiring and installed it (still haven't found the driv. side one).
- Rewired your radio harness. I think your gonna like it if you ever see it. I can't find the bracket for the other side, though.
- Check engine light went on.
- I tested your check engine light. The bulb is still good and works.

And it's not just me, your car hates 3rd gear. First trans with syncros that I've had to double clutch to get to go in gear. Oh, and was there always that crazy chip on the top of the windshield? I have my optima redtop riding shotgun with me everywhere I go. I finally know what DSM'ers mean when they say I'm happy everyday it starts. I'm gonna have that check engine code pulled up as soon as I get a chance. It went on, then the ecu got reset, then came back on so I don't think it's a misfire. Oh well, we'll see.

_________________
Read the rules!
avatar
Gdmbat85
Admin
Admin

Number of posts : 231
Age : 30
Location : Paramus
Car : 99 Eclipse Spyder GS-T
Registration date : 2008-02-04

View user profile

Back to top Go down

Re: Screaming Eagle's "talon" progress

Post by Gdmbat85 on Wed Apr 23, 2008 10:41 pm

I've found all (well most) the documentation and wiring diagrams I need to make sure the speed sensor is properly wired in. I've also located someone who had the same issue and fixed it. If it doesn't work, I'm going to have to guess that it's the sensor itself and see if I can test out the sensor.

_________________
Read the rules!
avatar
Gdmbat85
Admin
Admin

Number of posts : 231
Age : 30
Location : Paramus
Car : 99 Eclipse Spyder GS-T
Registration date : 2008-02-04

View user profile

Back to top Go down

Re: Screaming Eagle's "talon" progress

Post by Gdmbat85 on Thu Apr 24, 2008 12:51 am

Oh btw. Your car is now running on 93 octane. When I went to fill it up the other day, my gas attendant guy I always go to is so used to just putting premium in the car that he put in 93 in your car. She's now running on V-power, lol.

I've also noticed that your car seems to pull timing at around 2500rpms even with 93 in it. Maybe we can find a way to tune it and squeeze more power out of it.

_________________
Read the rules!
avatar
Gdmbat85
Admin
Admin

Number of posts : 231
Age : 30
Location : Paramus
Car : 99 Eclipse Spyder GS-T
Registration date : 2008-02-04

View user profile

Back to top Go down

Re: Screaming Eagle's "talon" progress

Post by ScreamingEagle on Thu Apr 24, 2008 1:42 am

Man, you've been busy!
Well, you just use the car as long as you need to, as long as you're fixing her up, I'm okay with it, and I'm sure she's happy.

As for the speedo wiring, I looked all over for people who have done this swap, and several write ups had that wiring the same, and that's the way I wired it up. I hope it's not the speed sensor, I can't get it out of the trans, I've tried- I was going to test it, but could never get it out. You don't need a jack to get to it, just pull the intake and the battery tray and it's right there in the middle of the rear motor mount bracket.

The amp should be wired just fine. It hasn't been touched at all, only the radio came out, and when Pat was messing with when he was trying to install it, I don't think he ever even went in the trunk. It sounds nice when it's all together, none of those paper speakers or crap like that. Watch out, I've got aluminum speakers in the front, so whatever you do, DON'T turn the treble up too much or you will be sorry. As for the bracket, everything that came from the radio area should be in the backseat. When I took it out that's where I put everything.

I don't know what's up with the drivetrain noise, I don't remember it being noisy before the clutch broke in half. Third has always been a little quircky, you really have to be careful when you're going there, and don't be hasty. I guess I can't complain since the trans was free. The shifter is really sloppy, at least compared to the TSi. I have a B&M in the TSi though, maybe that's why.

That crazy chip is a battle scar. It's nothing like what it used to be. One day, a few years ago, I was driving under the overpass by the high school and some hood was up there and shot the windshield. I went to the police, but they never found the perp. She's very sensitive about it, they fixed it like two days later (there was a big pulverized hole in the center that they had to fill) and I think she was upset that it wasn't replaced, because the next day she caught fire. Oh, by the way, speaking of fire, DON'T hook up the EGT gauge that's in the glove box unless you fix the EGT probe wire because the fire was the probe wire melting under the dash. If you look on the carpet by the fakie pedal, you'll see the burn.

Talon is rather tempermental, that's how I know she's a she. If you treat her nice, she'll work with you, but if not she can be a biotch! Paul and Talon never got along, he gets a little lippy with the DSM's and she makes him pay for it. TSunami likes to give him sass too, but he just punches her fender and she starts behaving. He knows he's not allowed to punch Talon, though.

As far as the 93, she usually gets 89 or 93. I put 87 in once at Sunoco, then she started overheating literally as I was pulling out of the gas station. I replace the t-stat and temp sensor and like two days later the ignition coil eats it. Replace that (MSD coil was cheaper than stock) and I'm not even kidding, the next day the HG disintegrates on the way to school. Had to get towed home. I told you she was sassy.

She's always seemed to pull timing around 2500rpm. Either that, or just pissing in fuel. I replaced the TPS already, I logged and idle was 15% and WOT was 72%, the new TPS did the same thing, and the 420a TPS is not adjustable. Also, if you log, she runs at a 15% or so fuel correction, then at 4800 rpm goes to lambada. I'm not sure if she's switching into open loop there, it happens whatever the load. speed. or throttle position, but always at 4800. I got a S-AFC years ago to try to correct this, but never installed it. If you feel spry, you're more than welcome to do so. I have all the 420a install instructions printed out and in the box, it may be in the trunk, either that or it's in the garage (if the hoodlums working on the VW didn't thieve it.) This is what led to the EGT gauge, when it was working, I never, NEVER, saw it go over 1400* (I think ideal is 1600* or so.) This would be so much easier if they had a 420a version of DSMlink.

Thanks again!
avatar
ScreamingEagle
Moderator
Moderator

Number of posts : 47
Age : 36
Location : Allentown, PA
Car : 07 Sky Redline, 97 Talon ESi, 95 Talon TSi AWD, 83 Eagle SX/4
Registration date : 2008-02-14

View user profile

Back to top Go down

Re: Screaming Eagle's "talon" progress

Post by Gdmbat85 on Thu Apr 24, 2008 8:26 am

Well I think I may have found out what the problem with the TPS was. I was showing a DSM friend your car (he was quite fond of it) and he noticed that the throttle cable was held on by 2 threads of 1 bolt.

The amp is either not turning on or the wires for all but the dash speakers are messed up or something. Only the dash speakers work right now (which really need to be replaced). I think it may have something to do with the 8 gauge wire just loosely chilling under your floor mat.....

I've gotten to the speed sensor before, and I'm thinking more and more that it's the sensor itself. I've connected what appears to be the back up light plug to the back up light switch and that doens't seem to work either so I'm thinking it's all the sensors in the tranny. I'll see if I can manage to get it out.

I need to get that logger off you so I can work out what's up with the TPS and timing.

_________________
Read the rules!
avatar
Gdmbat85
Admin
Admin

Number of posts : 231
Age : 30
Location : Paramus
Car : 99 Eclipse Spyder GS-T
Registration date : 2008-02-04

View user profile

Back to top Go down

Re: Screaming Eagle's "talon" progress

Post by Gdmbat85 on Thu Apr 24, 2008 9:59 am

Well I just finished up with your car for the night. I removed that brake lock cable which locks the shifter in park till the brake pedal is depressed. Hopefully, I can remove that key lock cable also.

I temporarily hooked up that 8 gauge power cable to the battery with the jumper cables to make sure that was the only problem. I did a rough tune on the system. Just need to find a spot to send the power cable through the firewall. I'm assuming that it was originally running where the clutch master cylinder is now and that's why it got pulled out.

Also, I found one of your caps for the front tokiko illumina adjustments.

_________________
Read the rules!
avatar
Gdmbat85
Admin
Admin

Number of posts : 231
Age : 30
Location : Paramus
Car : 99 Eclipse Spyder GS-T
Registration date : 2008-02-04

View user profile

Back to top Go down

Re: Screaming Eagle's "talon" progress

Post by Gdmbat85 on Fri Apr 25, 2008 12:40 am

Well the center console has been test fitted and everything fits and lines up well (as you saw in the pic I sent you). I'm gonna have to go pick up some more 8 gauge wire so it can reach the battery, unless you have some in the car that I just haven't found yet.

The throttle cable issue is fixed now. Found a second bolt in my Bucket O' Bolts. lol!

The backup lights work now. It was that the sensor plug not plugged in and a blown fuse.

Oh, and I fixed the punched in center vent. I hate when little things like that are screwed up.

She's coming along well. Just have to address that speedo issue. Hopefully, that'll fix the cruise control also. Guess well just have to wait and see what happens.

_________________
Read the rules!
avatar
Gdmbat85
Admin
Admin

Number of posts : 231
Age : 30
Location : Paramus
Car : 99 Eclipse Spyder GS-T
Registration date : 2008-02-04

View user profile

Back to top Go down

Re: Screaming Eagle's "talon" progress

Post by ScreamingEagle on Fri Apr 25, 2008 3:07 am

Oh, you spoil her so! I don't know if I should let her with you for too much longer, I might not get her back!

You can DL the logger program at http://obd-2.com/#download It's free just get the complete file, you just put it on your laptop, and I'll let you use the cable when I see you next.

Now that I think about it, the amp wire was run through where the master cylinder now is. And those dash speakers really do sound like ass, but they're terrible to replace so I never did. I have new ones somewhere, I just avoided changing them. That 8 Gauge, is that the really fat wire with the capsule fuse in it? I think we had some fatty wire running under the molding where the door closes, then up under the panel that the rear speaker is in. OOOoh don't go looking at those rear speakers, you're gonna be upset at the mounting. Let's just say that the system was put in the car long before we knew anything about fabrication and when we were inept when it came to using a dremel. Suspect
I can't get picture messages, but I vaguely remember what the center console looks like when it's in place.....

I don't know how the throttle cable got loose, but I assure you that it wasn't when I replaced the TPS. That was years ago I did that, it may have come loose after we had it all apart for the HG.

Ha hah ha, the center vent. I had those stupid vent clip air fresheners and when I went to change them the damn thing popped off. I'd fish it out and try to hook it back on, but it never stayed for long. Did you have to take the vents out to get to it? I would just grab it through the slats.

You know, I have another MT ecu for that car. I doubt it's the ecu that is malfunctioning and making the speedo etc not work, but it's worth a shot. We can try that too if you swing by to see Paul this weekend.

I think that's all for now. I should be around later, if you want to give a call when you get out of class.
avatar
ScreamingEagle
Moderator
Moderator

Number of posts : 47
Age : 36
Location : Allentown, PA
Car : 07 Sky Redline, 97 Talon ESi, 95 Talon TSi AWD, 83 Eagle SX/4
Registration date : 2008-02-14

View user profile

Back to top Go down

Re: Screaming Eagle's "talon" progress

Post by Gdmbat85 on Mon Apr 28, 2008 12:11 am

Well the SRS airbag light is now off but the CEL is still on. The center console looks to be completely finished and ready to be completely put back together.

I think the only things left are:
running the power wire for the amp
testing/fixing that speedo sensor
figuring out what that CEL is for
cleaning the inside of all the junk
giving her a nice detailing
and ofcourse, get my car fixed so I can give her back to you.

_________________
Read the rules!
avatar
Gdmbat85
Admin
Admin

Number of posts : 231
Age : 30
Location : Paramus
Car : 99 Eclipse Spyder GS-T
Registration date : 2008-02-04

View user profile

Back to top Go down

Re: Screaming Eagle's "talon" progress

Post by ScreamingEagle on Thu May 01, 2008 1:36 am

Hahaha! It's good I didn't let you borrow TSunami, I'd never get her back. A 5 mile drive did you in with that one, I can't imagine if you had her for a few weeks. She's not nearly as sexy as Talon, though.
avatar
ScreamingEagle
Moderator
Moderator

Number of posts : 47
Age : 36
Location : Allentown, PA
Car : 07 Sky Redline, 97 Talon ESi, 95 Talon TSi AWD, 83 Eagle SX/4
Registration date : 2008-02-14

View user profile

Back to top Go down

Re: Screaming Eagle's "talon" progress

Post by Gdmbat85 on Tue May 06, 2008 10:19 am

Well here's a new list of things that need to be done because I realized that I forgot to include a few things:

running the power wire for the amp
fixing the door lock
rewire that starter ground plug
replace all the panels
bleed the brakes
testing/fixing that speedo sensor
figuring out what that CEL is for
cleaning the inside of all the junk
giving her a nice detailing
and ofcourse, get my car fixed so I can give her back to you.


Last edited by Gdmbat85 on Tue May 06, 2008 10:22 am; edited 1 time in total

_________________
Read the rules!
avatar
Gdmbat85
Admin
Admin

Number of posts : 231
Age : 30
Location : Paramus
Car : 99 Eclipse Spyder GS-T
Registration date : 2008-02-04

View user profile

Back to top Go down

Re: Screaming Eagle's "talon" progress

Post by Gdmbat85 on Tue May 06, 2008 10:22 am

Today I cleaned a buncha crap outta your car. It took longer than I thought it would. I found that second door handle cover. I also got a chance to test the wiring to the speed sensor. Unfortunately, all the wires are testing out fine so I think the speed sensor is done.

_________________
Read the rules!
avatar
Gdmbat85
Admin
Admin

Number of posts : 231
Age : 30
Location : Paramus
Car : 99 Eclipse Spyder GS-T
Registration date : 2008-02-04

View user profile

Back to top Go down

Re: Screaming Eagle's "talon" progress

Post by ScreamingEagle on Fri May 09, 2008 4:08 am

Well the speed sensor is 40 bucks at AZ and they have it in stock. We can pick one up when you are out here next.

Sorry for the strange findings btw...

_________________
07 Saturn Sky Red/Line - unnamed as of yet - The TSi of the Kappa's
97 Eagle Talon ESi - "Talon"- A 2 hour drive and 1/8 tank of gas and 1/16 mile on the odometer....
95 Eagle Talon TSi AWD - "TSunami"- Converting people, one FWD at a time...
95 Subaru Impreza L - "Suby Two"- 110hp and AWD!!! (The most reliable car ever)
83 AMC Eagle SX/4 - "Eager" - AMC Eagles are like pickles... nobody's indifferent to them

~Here Flies The Screaming Eagle~
avatar
ScreamingEagle
Moderator
Moderator

Number of posts : 47
Age : 36
Location : Allentown, PA
Car : 07 Sky Redline, 97 Talon ESi, 95 Talon TSi AWD, 83 Eagle SX/4
Registration date : 2008-02-14

View user profile

Back to top Go down

Re: Screaming Eagle's "talon" progress

Post by Gdmbat85 on Fri May 09, 2008 11:01 am

hahaha it's ok. I didn't even know what some of the stuff was at first from how bunched up everything is. oh and do you need that bag of plywood? i was going to throw it out and then i was like..... well there has to be a good reason she has sheets of plywood in a bag.

_________________
Read the rules!
avatar
Gdmbat85
Admin
Admin

Number of posts : 231
Age : 30
Location : Paramus
Car : 99 Eclipse Spyder GS-T
Registration date : 2008-02-04

View user profile

Back to top Go down

Re: Screaming Eagle's "talon" progress

Post by ScreamingEagle on Sat May 10, 2008 1:28 am

Yea, I got that bag of plywood when I had to make a little pink house that had John Cougar Mellencamp and the band in it playing Little Pink Houses. It was pretty cool, I don't know if I even have it anymore, but there was a walkman and speaker inside, and they guys were all jumping around and singing Little Pink Houses. I'm not normally that weird, it was a project for 3D Design.

Just put the plywood back in when you bring her back. I'm sure we can use it somewhere, I could patch the hole that the cats chewed in the basement door when they ran out of food and rioted.

_________________
07 Saturn Sky Red/Line - unnamed as of yet - The TSi of the Kappa's
97 Eagle Talon ESi - "Talon"- A 2 hour drive and 1/8 tank of gas and 1/16 mile on the odometer....
95 Eagle Talon TSi AWD - "TSunami"- Converting people, one FWD at a time...
95 Subaru Impreza L - "Suby Two"- 110hp and AWD!!! (The most reliable car ever)
83 AMC Eagle SX/4 - "Eager" - AMC Eagles are like pickles... nobody's indifferent to them

~Here Flies The Screaming Eagle~
avatar
ScreamingEagle
Moderator
Moderator

Number of posts : 47
Age : 36
Location : Allentown, PA
Car : 07 Sky Redline, 97 Talon ESi, 95 Talon TSi AWD, 83 Eagle SX/4
Registration date : 2008-02-14

View user profile

Back to top Go down

Re: Screaming Eagle's "talon" progress

Post by Gdmbat85 on Thu May 15, 2008 7:10 am

Made some more progress on talon today.

Tensioned both surpentine belts to fix the belt squeal. The alternator tensioner was completely backed out and both belts were very loose.

Fixed the passanger side door lock. Never thought a tiny piece of plastic could be such a pain in the ass to get in.

Hooked up the air ducts in the console and got the passanger side panel back on.

_________________
Read the rules!
avatar
Gdmbat85
Admin
Admin

Number of posts : 231
Age : 30
Location : Paramus
Car : 99 Eclipse Spyder GS-T
Registration date : 2008-02-04

View user profile

Back to top Go down

Re: Screaming Eagle's "talon" progress

Post by Gdmbat85 on Thu May 15, 2008 7:15 am

Here's an updated list of what still has to be done. Everytime I take a few things off the list, something else is added and makes it even longer, lol.

run the power wire for the amp
rewire that starter ground plug
assemble rest of console
bleed the brakes
fix that speedo sensor
figure out what that CEL is for
clean the rest of the stuff inside the car
hook up a windshield washer fluid hose
replace the wiper blades
give her a nice detailing
and ofcourse, get my car fixed so I can give her back to you.

_________________
Read the rules!
avatar
Gdmbat85
Admin
Admin

Number of posts : 231
Age : 30
Location : Paramus
Car : 99 Eclipse Spyder GS-T
Registration date : 2008-02-04

View user profile

Back to top Go down

Re: Screaming Eagle's "talon" progress

Post by ScreamingEagle on Fri May 16, 2008 1:17 pm

fixing the battery cables -1
getting lock to mean alarm and unlock to mean unalarm instead of vice versa -1
clean the windshield with RainX bug remover -1
put a temporary spare old and used, but still with the rubber attached wiper on the passenger side -1

look at that, -4 that weren't even on the list

_________________
07 Saturn Sky Red/Line - unnamed as of yet - The TSi of the Kappa's
97 Eagle Talon ESi - "Talon"- A 2 hour drive and 1/8 tank of gas and 1/16 mile on the odometer....
95 Eagle Talon TSi AWD - "TSunami"- Converting people, one FWD at a time...
95 Subaru Impreza L - "Suby Two"- 110hp and AWD!!! (The most reliable car ever)
83 AMC Eagle SX/4 - "Eager" - AMC Eagles are like pickles... nobody's indifferent to them

~Here Flies The Screaming Eagle~
avatar
ScreamingEagle
Moderator
Moderator

Number of posts : 47
Age : 36
Location : Allentown, PA
Car : 07 Sky Redline, 97 Talon ESi, 95 Talon TSi AWD, 83 Eagle SX/4
Registration date : 2008-02-14

View user profile

Back to top Go down

Re: Screaming Eagle's "talon" progress

Post by zoomzoom6 on Sat May 17, 2008 2:35 am

FAIL!

should take the car back.. i think he'll get his car done way faster that way
he only has till the 1st anyway

_________________
avatar
zoomzoom6
Moderator
Moderator

Number of posts : 122
Age : 32
Location : bergen county
Car : mazdaspeed 6
Registration date : 2008-02-16

View user profile

Back to top Go down

Re: Screaming Eagle's "talon" progress

Post by ScreamingEagle on Mon May 19, 2008 12:56 pm

Only till the 1st?

See, George got the idea to convert his Spyder to AWD...I had barely anything to do with that. Cool

_________________
07 Saturn Sky Red/Line - unnamed as of yet - The TSi of the Kappa's
97 Eagle Talon ESi - "Talon"- A 2 hour drive and 1/8 tank of gas and 1/16 mile on the odometer....
95 Eagle Talon TSi AWD - "TSunami"- Converting people, one FWD at a time...
95 Subaru Impreza L - "Suby Two"- 110hp and AWD!!! (The most reliable car ever)
83 AMC Eagle SX/4 - "Eager" - AMC Eagles are like pickles... nobody's indifferent to them

~Here Flies The Screaming Eagle~
avatar
ScreamingEagle
Moderator
Moderator

Number of posts : 47
Age : 36
Location : Allentown, PA
Car : 07 Sky Redline, 97 Talon ESi, 95 Talon TSi AWD, 83 Eagle SX/4
Registration date : 2008-02-14

View user profile

Back to top Go down

Re: Screaming Eagle's "talon" progress

Post by Gdmbat85 on Mon May 19, 2008 1:27 pm

Yea, my deadline is June 1'st.

You didn't have much to do with the idea of converting the spyder..... you played a big role in making that dream a reality though. Or should I say TSunami did.

_________________
Read the rules!
avatar
Gdmbat85
Admin
Admin

Number of posts : 231
Age : 30
Location : Paramus
Car : 99 Eclipse Spyder GS-T
Registration date : 2008-02-04

View user profile

Back to top Go down

Re: Screaming Eagle's "talon" progress

Post by ScreamingEagle on Thu May 22, 2008 2:19 am

You better get crackin' then! The 1st isn't that far away. I'll see if I'm able to come out and help you, but Paul doesn't want to venture too far from the area, just in case, so we'll see what goes on. Let me know if you need anything that your donor car doesn't have, other than ABS of course.

_________________
07 Saturn Sky Red/Line - unnamed as of yet - The TSi of the Kappa's
97 Eagle Talon ESi - "Talon"- A 2 hour drive and 1/8 tank of gas and 1/16 mile on the odometer....
95 Eagle Talon TSi AWD - "TSunami"- Converting people, one FWD at a time...
95 Subaru Impreza L - "Suby Two"- 110hp and AWD!!! (The most reliable car ever)
83 AMC Eagle SX/4 - "Eager" - AMC Eagles are like pickles... nobody's indifferent to them

~Here Flies The Screaming Eagle~
avatar
ScreamingEagle
Moderator
Moderator

Number of posts : 47
Age : 36
Location : Allentown, PA
Car : 07 Sky Redline, 97 Talon ESi, 95 Talon TSi AWD, 83 Eagle SX/4
Registration date : 2008-02-14

View user profile

Back to top Go down

Re: Screaming Eagle's "talon" progress

Post by zoomzoom6 on Thu May 29, 2008 12:52 am

come june 1st if his car isn't done his parents are throwing it out or selling it. and i'd like to think i had a hand in getting him to go awd too.. but we all know that's a lie

_________________
avatar
zoomzoom6
Moderator
Moderator

Number of posts : 122
Age : 32
Location : bergen county
Car : mazdaspeed 6
Registration date : 2008-02-16

View user profile

Back to top Go down

Re: Screaming Eagle's "talon" progress

Post by zoomzoom6 on Thu May 29, 2008 12:55 am

the parts car he got DID come with abs.. so george is now the most lucky son of a bitch EVER

_________________
avatar
zoomzoom6
Moderator
Moderator

Number of posts : 122
Age : 32
Location : bergen county
Car : mazdaspeed 6
Registration date : 2008-02-16

View user profile

Back to top Go down

Re: Screaming Eagle's "talon" progress

Post by Gdmbat85 on Thu May 29, 2008 11:42 am

The rear end came with ABS, but the car doesn't. I'm still screwed cause the front end parts i need aren't ABS.

_________________
Read the rules!
avatar
Gdmbat85
Admin
Admin

Number of posts : 231
Age : 30
Location : Paramus
Car : 99 Eclipse Spyder GS-T
Registration date : 2008-02-04

View user profile

Back to top Go down

Re: Screaming Eagle's "talon" progress

Post by Sponsored content


Sponsored content


Back to top Go down

Page 1 of 2 1, 2  Next

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum